Aurora SPARC Linux
sparc tux

Errata for aurora builds

Home   Build 1.0   Build 0.4X  


build 1.0

Aurora SPARC Linux is quite strictly based on Red Hat Linux 7.3 i386, so you will find that this is mostly a list of the errata for that release and their status in aurora - plus a few fixes specific to aurora. (Thanks to Jeremy Huber and others for tracking the Red Hat errata page and building the packages.)

Build 1.0 was built on Jan 18th 2003. All errata for Red Hat Linux 7.3 i386 that were released up until Jan 14th 2003 and part of Jan 15th 2003 are already incorporated.

A lot of errata published by Red Hat between June and September 2003 where only updates to older errata in order to include the builds for IBM iSeries and pSeries. They have already been built for Aurora SPARC Linux when they were published for the first time.

security fix 2005-01-01:

mod_ssl-2.8.12-7.legacy
is in updates/1.0

security fix 2005-01-01: apache-1.3.27-6.legacy is in updates/1.0

security fix 2005-01-01: samba-2.2.12-0.73.3.legacy is in updates/1.0

security fix 2005-01-01: netpbm-9.24-9.73.4.legacy is in updates/1.0

security fix 2005-01-01: lha-1.14i-4.7.3.3.legacy is in updates/1.0

security fix 2005-01-01: ethereal-0.10.3-0.73.3.legacy is in updates/1.0

security fix 2005-01-01: rsync-2.5.7-2.legacy is in updates/1.0

security fix 2005-01-01: gaim-0.82.1-0.73.2.legacy is in updates/1.0

security fix 2005-01-01: sysstat-4.0.3-4.legacy is in updates/1.0

security fix 2005-01-01: libxml2-2.4.19-6.legacy is in updates/1.0

security fix 2005-01-01: xchat-1.8.9-1.73.2.legacy is in updates/1.0

security fix 2005-01-01: flim-1.14.4-4.7x.legacy is in updates/1.0

bug fix 2005-01-01: sysklogd-1.4.1-14.legacy is in updates/1.0

security fix 2005-01-01: cadaver-0.22.1-1.legacy is in updates/1.0

security fix bug fix 2005-01-01: wu-ftpd-2.6.2-15.7x.legacy is in updates/1.0

security fix 2005-01-01: cvs-1.11.1p1-16.legacy is in updates/1.0

security fix 2005-01-01: mod_python-2.7.8-1.7.3.2.legacy is in updates/1.0

security fix 2005-01-01: utempter-0.5.2-6.7.x.1.legacy is in updates/1.0

security fix 2005-01-01: openssl-0.9.6b-36.7.sparc, openssl095a-0.9.5a-24.7.3.sparc, openssl096-0.9.6-25.7.sparc is in updates/1.0

security fix 2005-01-01: metamail-2.7-29.7.x.legacy is in updates/1.0

security fix 2005-01-01: libtool-1.4.2-13.legacy is in updates/1.0

security fix 2005-01-01: pwlib-1.2.12-4.legacy is in updates/1.0

security fix 2005-01-01: mc-4.5.55-6.legacy is in updates/1.0

bug fix2004-01-05: dateconfig-0.7.5-7sparc is in updates/1.0. The orginal package contained some i386 code, see Bug #88.

bug fix2004-01-05: xmlto-0.0.8-3 is in updates/1.0. The SRPM was included in the original distribution, but the binary (noarch) rpm was missing, see Bug #91.

security fix2003-12-18: apache-1.3.27-4 is in updates/1.0

security fix2003-12-16: lftp-2.4.9-2 is in updates/1.0

security fix2003-12-12: gnupg-1.0.7-13 is in updates/1.0

security fix2003-12-05: rsync-2.5.7-0.7 is in updates/1.0

security fix2003-11-25: XFree86-4.2.1-13.73.23sparc is in updates/1.0

security fix2003-11-25: stunnel-3.26-1.7.3 is in updates/1.0

security fix2003-11-25: iproute-2.4.7-7.73.1 is in updates/1.0

security fix2003-11-25: pan-0.11.4-1 is in updates/1.0

security fix2003-11-18: epic-1.0.1-15.7.x is in updates/1.0

security fix2003-11-17: zebra-0.92a-5.7.3 is in updates/1.0

security fix2003-11-17: postgresql-7.2.4-5.73 and friends are in updates/1.0

security fix2003-11-13: glibc-2.2.5-44sparc.1, glibc64-2.2.5-44sparc.1, nscd-2.2.5-44sparc1 are in updates/1.0.

security fix2003-11-12: ethereal-0.9.16-0.73.1 is in updates/1.0

security fix2003-11-04: fileutils-4.1-10.4 is in updates/1.0

security fix2003-10-15: mysql-3.23.58-1.73 is in updates/1.0

security fix2003-10-15: sane-backends-1.0.7-6.2sparc is in updates/1.0

security fix2003-10-15: perl-5.6.1-36.1.73 is in updates/1.0

security fix2003-10-15: openssl-0.9.6b-35.7sparc, openssl095a-0.9.5a-23.7.3, openssl096-0.9.6-23.7 are in updates/1.0

bug fix2003-10-15: ucd-snmp-4.2.5-8.73.1 is in updates/1.0

security fix2003-09-22: apache-1.3.27-3, mod_ssl-2.8.12-3 are in updates/1.0

security fix2003-09-22: perl-5.6.1-36.1.73 is in updates/1.0

security fix2003-09-18: openssh-3.1p1-14 is in updates/1.0

security fix2003-09-18: sendmail-8.11.6-27.73 is in updates/1.0

security fix2003-09-18: kdebase-3.0.5a-0.73.4 is in updates/1.0

security fix2003-09-11: gtkhtml-1.0.2-1.1 is in updates/1.0

security fix2003-08-29: pam_smb-1.1.6-9.7 is in updates/1.0

security fix2003-08-29: iptables-1.2.8-8.72.3, iptables-ipv6-1.2.8-8.72.3 are in updates/1.0

security fix2003-08-29: gdm-2.2.3.1-23 is in updates/1.0

security fix2003-08-29: unzip-5.50-31 is in updates/1.0

security fix2003-08-29: kdelibs-3.0.5a-0.73.2sparc is in updates/1.0

security fix2003-08-29: kde*.3.0.5a is in updates/1.0. The full list is here.

security fix2003-08-28: galeon-1.2.11-1.7.3 is in updates/1.0

bug fix2003-08-28: glibc-2.2.5-43sparc.1, glibc64-2.2.5-43sparc.1 are in updates/1.0. These packages only fix a bug that prevented the rebuild of galeon.

security fix2003-08-27: ddskk-11.6.0-11.73, ddskk-xemacs-11.6.0-11.73 are in updates/1.0

security fix2003-08-27: postfix-1.1.12-0.7 is in updates/1.0

security fix2003-08-27: wu-ftpd-2.6.2-11.73.1 is in updates/1.0

security fix2003-08-27: XFree86-4.2.1-13.73.3sparc is in updates/1.0 (Build -13.73.3 without "sparc" was missing some files and had the "b for an l" bug.)

security fix2003-08-26: openssh-(*-)3.1p1-8 is in updates/1.0

security fix2003-08-26: stunnel-3.22-5.7.3 is in updates/1.0

security fix2003-08-26: semi-1.14.3-15, semi-xemacs-1.14.3-15 are in updates/1.0

security fix2003-08-06: xpdf-1.00-7, -chinese*, -japanese, -korean are in updates/1.0

security fix2003-07-16: XFree86-4.2.1-13.73.3 and friends are in updates/1.0

security fix2003-07-15: mozilla-1.0.2-2.7.3 and friends are in updates/1.0

security fix2003-07-14: nfs-utils-0.3.3-6.73 is in updates/1.0

security fix2003-07-03: ethereal-0.9.13-1.73.1, ethereal-gnome-0.9.13-1.73.1 are in updates/1.0

security fix2003-07-01: unzip-5.50-11 is in updates/1.0

security fix2003-06-25: gv-3.5.8-18.7x, ggv-1.0.2-5.1 is in updates/1.0

security fix2003-06-25: ypserv-2.8-0.73E is in updates/1.0

security fix2003-06-18: xpdf-1.00-6, -chinese*, -japanese, -korean are in updates/1.0

security fix2003-06-06: hanterm-xf-2.0.5-5.7.4 is in updates/1.0

security fix2003-06-03: kon2-0.3.9b-14.7.3.1 does not apply (is specific to i386).

security fix2003-05-30: ghostscript-6.52-9.5 is in updates/1.0

security fix2003-05-27: cups-1.1.14-15.4, -libs, -devel is in updates/1.0

security fix2003-05-20: gnupg-1.0.7-7 is in updates/1.0

security fix2003-05-16: lv-4.49.4-3.7x.1 is in updates/1.0

security fix2003-05-15: arpwatch-2.1a11-17.7.3.3, libpcap-0.6.2-17.7.3.3, tcpdump-3.6.3-17.7.3.3 are in updates/1.0

security fix2003-05-13: xinetd-2.3.11-1.7x is in updates/1.0

security fix2003-05-06: redhat-config-network-1.0.4-2 is in updates/1.0

security fix2003-05-02: mysql-3.23.56-1.73, mysql-devel-3.23.56-1.73, mysql-server-3.23.56-1.73 is in updates/1.0

security fix2003-05-02: mod_auth_any-1.2.2-2 is in updates/1.0

security fix2003-05-01: man-1.5j-7.7x.0 is in updates/1.0

security fix2003-04-29: zlib-1.1.4-8.7x is in updates/1.0

security fix2003-04-25: cvs-1.11.1p1-8.7 is in updates/1.0

security fix2003-04-25: micq-0.4.10.2-1 is in updates/1.0

security fix2003-04-24: LPRng-3.8.9-4.1 is in updates/1.0

security fix2003-04-23: arpwatch-2.1a11-17.7.3.2, libpcap-0.6.2-17.7.3.2, tcpdump-3.6.3-17.7.3.2 are outdated.

security fix2003-04-23: ethereal-0.9.11-1.73.0 is in updates/1.0

security fix2003-04-14: glibc-2.2.5-43, glibc64-2.2.5-43 are in updates/1.0

security fix2003-04-14: samba-2.2.7-3.7.3 is in updates/1.0

security fix2003-04-14: mgetty-1.1.30-0.7 is in updates/1.0

security fix2003-04-14: netpbm-9.24-9.73.2 is in updates/1.0

security fix2003-04-14: balsa-1.2.4-7.7.3 is in updates/1.0

security fix2003-04-14: samba-2.2.7-2.7.3 is outdated.

security fix2003-04-14: openssl-0.9.6b-32.7 has not been built yet.

security fix2003-04-14: evolution-1.0.8-9.7x.1 is in updates/1.0

security fix2003-04-14: sendmail-8.11.6-25.73 is in updates/1.0

security fix2003-04-14: kernel has not been patched yet. Aurora kernels are based on a different kernel tree than Red Hat 7.3/i386.

security fix2003-04-14: krb5-1.2.4-11 is in updates/1.0

security fix2003-04-14: rxvt-2.7.8-4 is in updates/1.0

security fix2003-04-14: sendmail-8.11.6-25.72 is outdated.

security fix2003-04-14: file-3.39-8.7x is in updates/1.0

security fix2003-04-14: mew-2.2-5.7x is in updates/1.0

security fix2003-04-14: openssl-0.9.6b-30.7 is in updates/1.0

security fix2003-04-14: kernel has not been patched yet. Aurora kernels are based on a different kernel tree than Red Hat 7.3/i386.

security fix2003-04-14: vnc-3.3.3r2-28.2 is in updates/1.0

security fix2003-04-14: shadow-utils-20000902-9.7 is in updates/1.0

security fix2003-02-28: python-1.5.2-43.73, python2-2.2.2-11.7.3 is in updates/1.0

security fix2003-02-28: fileutils-4.1-10.1 is in updates/1.0

security fix2003-02-28: lynx-2.8.4-18.1 is in updates/1.0

security fix2003-02-28: pam-0.75-46.7.3 is in updates/1.0

security fix2003-02-08: xpdf-1.00-5 is in updates/1.0

security fix2003-02-08: w3m-0.3.1-4.7x.1 is in updates/1.0/

security fix2003-02-08: openldap-2.0.27-2.7.3, openldap12-1.2.13-8 are in updates/1.0/

security fix2003-02-08: WindowMaker-0.80.0-9.3 is in updates/1.0/

security fix2003-02-08: kernel has not been patched yet. Aurora kernels are based on a different kernel tree than Red Hat 7.3/i386.

security fix2003-02-03: krb5-1.2.4-4 is outdated.

security fix2003-01-21: python-1.5.2-42.73, python2-2.2.2-3.7.3 is outdated

security fix2003-01-20: cvs-1.11.2-8 is in updates/1.0/

security fix2003-01-15: vim-6.1-18.7x.2 is in updates/1.0/


build 0.4X

CLOSED

Now that build 1.0 is out, we will not publish any more official errata for builds 0.4X but contrate on build 1.0. Since builds 0.4X and 1.0 share the rpm set of Red Hat Linux 7.3 for i386, all rpms for Aurora build 1.0 should install fine on 0.4X if you honour the perhaps changed dependencies.

security fix2002-05-06:

mod_python-2.7.8-1
is already in aurora build 0.42.

bugfix2002-05-09: kernel does not apply.

bugfix2002-05-09: evolution-1.0.3-6 is already in build-0.42.

security fix2002-05-09: netfilter information leak does not apply.

security fix2002-05-10: perl-Digest-MD5-2.20-1 is already in aurora build 0.42.

security fix2002-05-13: mozilla-0.9.9-12.7.3 is already in aurora build 0.42.

security fix2002-05-20: fetchmail-5.9.0-11 is already in aurora build 0.42.

bugfix2002-05-30: sane-backends-1.0.7-6.1 is already in build-0.42.

security fix2002-06-03: ghostscript-6.52-9.4 is already in aurora build 0.42.

bugfix2002-06-03: dateconfig-0.7.5-7 is already in build 0.42.

security fix2002-06-04: bind-9.2.1-0.7x is outdated.

security fix2002-06-04: xchat-1.8.9-1.73.0 is already in aurora build 0.42.

security fix2002-06-04: ethereal-0.9.4-0.7.3.0 is outdated.

security fix2002-06-04: nss_ldap-189-2 is outdated.

bugfix2002-06-05: ucd-snmp-4.2.5-7.73.0 is already in build 0.42.

security fix2002-06-06: mailman-2.0.11-1 is outdated.

security fix2002-06-09: LPRng-3.8.9-4 is already n aurora build 0.42.

bugfix2002-06-20: kernel does not apply.

bugfix2002-06-21: glibc is outdated.

security fix2002-06-27: openssh-3.1p1-6 is already in aurora build 0.42.

security fix2002-06-28: apache-1.3.23-14 is already in aurora build 0.42.

security fix2002-07-02: squid-2.4STABLE6-6.7.3 is in updates/0.4X.

bugfix2002-07-08: psmisc-20.2-3.73 is in updates/0.4X.

security fix2002-07-16: mod_ssl-2.8.7-6 is in updates/0.4X.

bugfix2002-07-16: miniChinput-0.0.3-20 is in updates/0.4X.

bugfix2002-07-16: gdb-5.2-2 is in updates/0.4X.

bugfix2002-07-17: gcc-2.96-112 is in updates/0.4X.

security fix2002-07-22: glibc-2.2.5-37 is outdated.

security fix2002-07-29: openssl-0.9.6b-24 is outdated.

security fix2002-07-29: util-linux-2.11n-12.7.3 is in updates/0.4X.

security fix2002-07-30: mm-1.1.3-8 is in updates/0.4X.

security fix2002-08-05: openssl-0.9.6b-28 is in updates/0.4X.

security fix2002-08-05: gaim-0.59-0.7.3 is outdated.

security fix2002-08-08: bind-9.2.1-1.7x.2 is in updates/0.4X.

enhancement2002-07-17: redhat-lsb-1.2.0-1 has not been ported yet.

security fix2002-08-12: glibc-2.2.5-39 is outdated.

security fix2002-08-14: libpng-1.0.14-0.7x.3 is in updates/0.4X.

security fix2002-08-20: krb5-1.2.4-2 is outdated.

security fix2002-08-20: kernel-2.4.18-10 does not apply.

security fix2002-08-22: mailman-2.0.13-1 is in updates/0.4X.

security fix2002-08-23: php-4.1.2-7.3.4 is in updates/0.4X.

security fix2002-08-28: scrollkeeper-0.3.4-5 is in updates/0.4X.

security fix2002-08-28: ethereal-0.9.6-0.73.0 is in updates/0.4X.

security fix2002-08-30: pxe-0.1-31.99.7.3 does not apply (i386 only).

security fix2002-09-05: wordtrans-1.1pre8-11 is in updates/0.4X.

security fix2002-09-09: gaim-0.59.1-0.7.3 is in updates/0.4X.

security fix2002-09-18: tar-1.13.25-4.7.1 is in updates/0.4X (unzip is already in 0.42).

security fix2002-10-03: glibc-2.2.5-40 is in updates/0.4X.

security fix2002-10-03: nss_ldap-189-4 is in updates/0.4X.

security fix2002-10-07: fetchmail-5.9.0-20 is in updates/0.4X.

security fix2002-10-08: tetex-1.0.7-47.1 is in updates/0.4X.

security fix2002-10-09: ggv-1.0.2-5.1, gv-3.5.8-18.7x are in updates/0.4X.

security fix2002-10-09: galeon-1.2.6-0.7.3, mozilla-1.0.1-2.7.3 and nautilus-1.0.6-16 are in updates/0.4X.

bugfix2002-10-10: rhn_register-2.8.27-1.7.3, up2date-2.8.39-1.7.3 have not been ported yet.

security fix2002-10-14: xinetd-2.3.9-0.73 is outdated.

security fix2002-10-15: hwdata-0.14.1-1, kernel-2.4.18-17.7.x, modutils-2.4.18-3.7x kernel and modutils do not apply, hwdata is in updates/0.4X.

security fix2002-10-24: ypserv-2.5-2.7x is in updates/0.4X.

security fix2002-10-29: kernel-2.4.19-1.2 is in updates/0.4X. It fixes various bugs in the kernels from builds 0.4 and 0.42 and the security issues RHSA-2002-206, RHSA-2002-158 and RHSA-2002-110.

security fix2002-11-06: krb5-1.2.4-3 is in updates/0.4X.

security fix2002-11-06: glibc-2.2.5-42 is in updates/0.4X.

bug fix2002-11-11: gcc-2.96-112 is in updates/0.4X.

security fix2002-11-16: kernel-2.4.18.7.x is specific to X86, does not apply to aurora

security fix2002-11-21: samba-2.2.7-1.7.3 is in updates/0.4X.

security fix2002-11-25: apache-1.3.27-2 and mod_ssl-2.8.12-2 is in updates/0.4X.

security fix2002-12-03: xinetd-2.3.7-4.7x is in updates/0.4X. ATTENTION: the current erratum release (2.3.7) is smaller than an older erratum (2.3.9) - just like in RedHat 7.3 i386. Seems RedHat had good reasons to downgrade.

security fix2002-12-04: Canna-3.5b2-62.7.3 is in updates/0.4X.

security fix2002-12-04: wget-1.8.2-4.73 is in updates/0.4X.

security fix2002-12-04: arts-1.0.3-0.7.1, kde-i18n-3.0.3-0.7.3, kdeaddons-3.0.3-0.7, kdeadmin-3.0.3-0.7, kdeartwork-3.0.3-0.7.1, kdebase-3.0.3-0.7.2, kdebindings-3.0.3-0.7.1, kdeedu-3.0.3-0.7, kdegames-3.0.3-0.7, kdegraphics-3.0.3-0.7.2, kdelibs-3.0.3-0.7.2, kdemultimedia-3.0.3-0.7.1, kdenetwork-3.0.3-0.7.2, kdepim-3.0.3-0.7, kdesdk-3.0.3-0.7, kdetoys-3.0.3-0.7, kdeutils-3.0.3-0.7, kdevelop-2.1.3-0.7.1, qt-3.0.5-7.14 have not been built yet.

bug fix2002-12-11: mm-1.1.3-11 is in updates/0.4X.

security fix2002-12-17: fetchmail-5.9.0-21.7.3 is in updates/0.4X.

security fix2003-01-02: pine-4.44-7.73.0 has not been ported yet.


Last revision: Thu Dec 18 2003 17:00 GMT+1 ~ingotee